Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Problem with authentication

websvn
Discussion topic

Back to topic list

Problem with authentication

Reply

Author catsclaw
Full name Chris Bergstresser
Date 2008-01-03 22:05:04 PST
Message Hi all --

   I just downloaded and installed WebSVN, and it works *except* for
the authentication. I have a local SVN repository which is called
"adv". There's an "adv.access" and a "adv.passwd" file; these work to
restrict access to the repository.
   I added my repository to WebSVN (using $config->addRepository and
the file:/// url) and that worked. I then added a .htaccess file to
the WebSVN root, pointing to the adv.passwd file, and that worked as
well, requiring me to log in before letting me browse the repository.
But when I added the "$config->useAut​henticationFile" call pointing at
my adv.access file, my repository no longer appears in WebSVN. I
don't get any errors, either -- my repository simply doesn't appear in
the list.
   What am I doing wrong?

-- Chris

« Previous message in topic | 1 of 3 | Next message in topic »

Messages

Show all messages in topic

Problem with authentication catsclaw Chris Bergstresser 2008-01-03 22:05:04 PST
     Re: Problem with authentication Kelvin Luck <kelvin at kelvinluck dot com> Kelvin Luck <kelvin at kelvinluck dot com> 2008-01-06 06:15:54 PST
         RE: [WebSVN] Re: Problem with authentication webpost at tigris dot org webpost at tigris dot org 2013-11-30 13:15:28 PST
Messages per page: