Login | Register
My pages Projects Community openCollabNet

Discussions > dev > [WebSVN] lighttpd+fastcgi+websvn error in chroot environmet produce "Error running this command: /usr/local/bin/svn --config-dir /tmp --version"

websvn
Discussion topic

Back to topic list

[WebSVN] lighttpd+fastcgi+websvn error in chroot environmet produce "Error running this command: /usr/local/bin/svn --config-dir /tmp --version"

Reply

Author Denis Lapshin <deniza at mindall dot org>
Full name Denis Lapshin <deniza at mindall dot org>
Date 2015-01-21 10:58:16 PST
Message I'm using Lighttpd with fastcgi module working in chroot environment.
I can run "#/usr/local/bin/svn --config-dir /tmp --version" command
successfully just after switching into chroot by running: "#chroot /var/www"

But WebSVN shows "Error running this command: /usr/local/bin/svn
--config-dir /tmp --version"
The repository was added into include/config.php

What I missed out to work WebSVN properly?

php-code.ini has:

safe_mode_allowed_env_vars = PHP_
cgi.fix_pathinfo=1
file_uploads = On


There is a part from lighttpd.conf below:

  fastcgi.server = ( ".php" =>
                                ( "localhost" =>
                                 (
                                    "socket" => "/tmp/php-fcgi-code.socket",
                                    "bin-path" =>
"/usr/local/bin/php-fastcgi-5.3 -c /etc/php-5.3/php-code.ini",
                                    "max-procs" => 1,
                                    "idle-timeout" => 20,
                                    "bin-environment" => (
                                         "PHP_FCGI_CHILDREN" => "2",
                                         "PHP_FCGI_MAX_REQUESTS" => "1000"
                                         ),
                                    "bin-copy-environment" => (
                                         "PATH","SHELL"
                                         ),
                                         "broken-scriptfilename" => "enable"
                                 )
                               )
                             )
                         }


Thanks.

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[WebSVN] lighttpd+fastcgi+websvn error in chroot environmet produce "Error running this command: /usr/local/bin/svn --config-dir /tmp --version" Denis Lapshin <deniza at mindall dot org> Denis Lapshin <deniza at mindall dot org> 2015-01-21 10:58:16 PST
Messages per page: